View Single Post
TorqueHead TorqueHead is offline
Registered User
I have not worked on the car for a month or so, so not too much to report. I did get the fuel circuit completely flushed and working. Fuel now flows from tank to engine and back to tank just like it is supposed to. I have not pulled the injectors and am hoping I don't have to.

The parts have arrived for my crank sensor plug rebuild and it looks like everything will fit. When I know it all fits I will provide details in another post. FYI, as a backup I ordered a new crank sensor with the old style plug but the vendor sent the new style. So be warned and make a phone call first if you are looking for a sensor with the old style plug. It seems that some vendors will substitute without even asking and I really don't want to cut into my wiring harness and deal with sensor wires that are too short to use the factory wire routing. My goal is to keep the car as original as possible so I am sticking with the old style plugs on all my sensors.

Once the sensor plugs are fixed I could attempt to fire it up, but I probably should at least check the valve clearance while I have so many parts already out of the way. From what I have read, this can be somewhat challenging and requires removing a lot more parts. Sigh. I should be able to get back to working on the car soon and will have more updates. Thanks for asking!
Old 06-06-2018, 05:19 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #83 (permalink)