Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > 2- BMW Forums > BMW Technical Forums > 101 Projects Discussion Forum: BMW 3-Series

Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Chunk (guest)
Guest
 
Posts: n/a
PS: that would be RPM gauge stuck at 1100 RPM.
The X3 starts, however the RPM guage doesn't move and
all dash lights are off!!!!

__________________
This post was auto-generated based upon a question asked on our tech article page here: BMW E30/E36 Electical Problem Troubleshooting | 3-Series (1983-1999) | Pelican Parts DIY Maitenance Article
Old 10-13-2017, 07:08 AM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)
Moderator
 
Join Date: Jul 2012
Posts: 3,189
Likely a faulty battery or faulty alternator. I would test the battery and alternator so determine which it is.

- Nick
Old 10-13-2017, 07:08 AM
  Pelican Parts Technical Article Directory    Reply With Quote #2 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 05:46 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2016 Pelican Parts - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.