View Single Post
Gumba11 Gumba11 is offline
Registered User
 
Gumba11's Avatar
 
Join Date: Feb 2005
Location: Portland
Posts: 845
Porsche Crest Help with CIS driveability problem....

I was taking my car to a show today and I experienced full time what was something that would happen only once in a while before and now has become a constant issue.

Vehicle 1977 930 3.0 Litre
Now 3.2 Litre , 8:1 CR, 964 cams, K27 - 7200 turbo, Full bay IC, GHL headers, and muffler, Stock euro fuel system with new fuel and air filter. I hope this info makes for an easier response.

On acceleration with little to no boost the car runs out great however with moderate throttle the car starts to quiver and bog and smoke black from the exhaust. When you give full throttle this gets much worse and seems like it wants to die then all of the sudden it will pull to red line in first gear. Once you shift into second gear or any gear after the symtoms are the same but the car will not get passed the bogging problem as easily if at all.

Cold and hot starts are never a problem although it does have an issue also with a wandering idle that is influenced heavily by ambient temperature. Idle is usually too high in cold weather and too low when warm outside.

This issue makes climbing hills a real downer. I miss the days of pulling like a freight train on hills and passing anything but a gas station.

Can anyone give me any pointers on how to get my baby back in good health?

Thanks in advance!
__________________
77 930 "P Zilla" 3.2 Litre w / EFI conversion
Old 02-16-2007, 11:46 PM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)