View Single Post
Greyhound - 930 Greyhound - 930 is offline
Registered User
 
Greyhound - 930's Avatar
 
Join Date: Mar 2007
Location: New Zealand
Posts: 19
Smile Fast cold idle 930 sorted

Hello to the forum and hopefully someone can help me with this inquiry.
I have a 1979 930 which has a cold idle speed problem. When the car is first started cold it fires on 2,3,4 and finally all 6 cyliders before settling in to an idle speed of around 2000rpm. Once the car is driven to warm the idle comes down to a respectable 7-800rpm. I could almost live with this apart from the fact that if I leave the car for more than 10 minutes anywhere it's back to stage one again even after it has been driven for some time and the car is warm. To add to this if the weather is above about 22 deg. C (72 deg. F) the problem is less severe but still far from right. As well as this, now when full boost comes on the engine shuts off completely and the ignition needs to be turned off and the engine re-started. This can be done immediately and the engine will start again no problem. When I first had the engine re-built about 4k miles ago there was a problem with a blocked wastegate atmosphere pipe which had a similar initial effect after creating an overboost, but the engine fired again as soon as the revs droped and boost was lost but this problem is different again.
Any suggestions re these two problems would be great. Thanks Konrad.

Last edited by Greyhound - 930; 03-26-2007 at 02:30 AM..
Old 03-24-2007, 01:07 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)