View Single Post
les_garten les_garten is offline
Macht Schnell
 
les_garten's Avatar
 
Join Date: Jun 2003
Location: PSL, FL
Posts: 861
Quote:
Originally posted by DRV2FST
les, thanks for the information about the Tec3r. At least I know it is not just me.

kirk
Ditto my friend. I was "glad" to hear someone else had the problem. Incidentally, I have it on Excellant authority that this problem was rampant. I told them that I coldn't be the only one after 5 straight in a row didn't work from day one. Now these rubes kept sending me non-functional units that "I" had to keep paying for the freakin' postage. They were rude, condescending, and basically *********S about the whole thing. They insisted I was the only guy having this problem and it was my install that was causing issues.
The way I got it fixed was to send it to Clewitt, and said, test it, confirm that it does not work, get it back , test it, confirm it works, send it to me. This resulted in the first functional unit I had. They also kept insisting that the one's I was sending to them had no flaws and functioned perfectly. That was BS also. I had a IAC tester that had not problem actuating the IAC valce. The tester also indicated signal failure on every unit they sent me. This problem went on for months. I really was ticked off at the way they treated me and won't buy anything from them in the future. YMMV.

Les
__________________
---Les Garten---85 930, Andial IC, GHL Headers, Fabspeed Dual, K-27 HF2, 3.4 JE Full Finned 7.5:1 CR, 964 CAM'd, Carerra 3.2 Manifold Cut/Flipped, Tec3r, Siemans 55#, GSF Fuel Rails, Clewett Crank Trigger, Clewett Cam Trigger,Dual Plugged, ARP Head Studs/Rod Bolts, Clewett Wires.Tial 46mm WG, Tial 50mm BOV, WEVO Shifter,934 Boost Gauge, Wideband EGO Sensor/Gauge, C2T Head Gaskets, '88 MB 300TE,BMW R100RT
Old 06-16-2007, 02:03 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #18 (permalink)