View Single Post
AFM744 AFM744 is offline
Cynical Misanthrope
 
AFM744's Avatar
 
Join Date: Dec 2001
Location: Campbell, CA
Posts: 382
Send a message via Yahoo to AFM744
I think I fixed it!
I assumed since the car smogged well that the base CO was good. I also speculated that fixing the air leak would affect that, but I didn't actually CHECK IT on open-loop. So this morning I drive it with the air leak fixed but the O2 unplugged and saw AFRs at 10:1 at idle and cruising (that's how bad the air leak was). So I just got back from a lunch drive where I started with a 10mi warm-up, set the idle AFR at 13.4, drove 10mi, car ran great. Then I plugged the O2 back in, car ran great AND on cruise and idle I have lambda. But the best part? No stumble!!!
Synopsis Theory: Car was tuned while it had an air leak (lots of compensating fuel), I fixed the air leak, now engine runs rich as hell, except the O2 system compensates with frequency valve. This control pressure imbalance screws up the accel enrichment. I unplugged O2, now engine runs open-loop, rich as hell, but the frequency valve was not pulling on the control pressure so the enrichment works properly and the stumble disappeared. Reset base AFR, plug in O2, engine runs great and I don't smell like a Shell station.
__________________
X-1, AFM744, Jon, '92 C2 Turbo
JE 8:1 pistons, 964 cams, 38mm intakes ported/polished/twinplugged, ARP hardware, B&B headers/exhaust, 355whp. Full-blown GT35R 3.2 intake EFI pending...
Where my misspent time and money is currently going.
Old 10-26-2007, 01:08 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #13 (permalink)