View Single Post
bmachnee bmachnee is offline
Registered User
 
bmachnee's Avatar
 
Join Date: Dec 2004
Location: Detroit
Posts: 19
930 Fuel Pump Fuse Issues

Unfortunatly this last weekend I finally had a issue with my 87 930. I just got done bragging about its reliability when it happened. After pulling it out of the garage to do some work on another vehicle I shut it off and let it sit all day and when I went to put it back in its home it would not fire. So I pushed it into its spot and pondered what it may be at first I thought it could be a DME relay or fuel pump relay. Well last night I finally got some time to take a good look at it and after taking the fuel pump relays out of the equation I got out my multimeter and started looking at fuses. I found that the fuel pump fuse was burnt and the fuse box connections to be corroded and chared also. No other fuses have any isssues and all the rest of the wiring looked good to. After a little research I found that the original aluminum fuses tend to corrode and for some reason it looks like it was arcing in the fuse box and finally chared enough to break the connection. After I bypassed the fuse block temporarily and put power to the fuel pump the car started right up. I guess my question is if anyone else has had this issue also with the factory fuses? Needless to say I have a new set of brass and copper fuses on their way to my door so that I dont have this issue again.
Old 11-01-2007, 06:00 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)