View Single Post
fredmeister fredmeister is offline
Smart quod bastardus
 
fredmeister's Avatar
 
Join Date: Oct 2002
Location: Baltimore, MD, USA
Posts: 2,232
Garage
Great thread guys.....
I am having similar issues with pinging last nite since I changed from a 0.8bar boost spring to a 1.0bar spring.
My car is a 79 930 with the dual port can, the boost retard is open to atmosphere. Vacuum side is connected as normal.
Checked timing and here is what I have which confuses me:
at idle of 1000rpm..... timing = (neg) 7 degrees BTDC VACUUM PORT CONNECTED
at idle of 1000rpm..... timing = (neg) 29 degrees BTDC VACUUM PORT DISCONNECTED
Honestly I was shocked because I thought that the 29 was aweful high at idle because as I rev to 4000rpm (NOT DONE AS YET, SO CANNOT REPORT RESULTS) I expect the mechanical advance to go even higher.
Now the safe limit from other posts I have read under full boost and high revs indicates 26-28 degrees max timing BTDC......I wonder what it will be when I run it up to 4000rpm with vacuum disconnected.
Questions:
1) In short, how much more advance does the mechanical advance add by itself?
2) Are my mechanical advance weights frozen at idle to explain the above results so far?
__________________
1979 930 Turbo....3.4L, 7.5to1 comp, SC cams, B&B intercooler, Snow Perf water/meth injection, Rarlyl8 headers, Garret GTX turbo, 36mm ported intakes, Innovate Auxbox/LM-1, custom Manually Adjustable wastegate housing (0.8-1.1bar),--running 0.7bar max
---"When you're racing it's life! Anything else either before or after, is just waiting"
Old 04-10-2008, 02:41 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #36 (permalink)