View Single Post
voitureltd voitureltd is offline
Registered User
 
Join Date: Feb 2008
Location: Bayside Wi
Posts: 2,331
Tach vasilates and blows fuel pump fuse

On my Bone stock 1987 930 with just 30K miles. It started when at a car show it would not start. My son drove it there for the first time since winter storage which I drove it from a week before, No problems. After a long cranking it started and he drove it home carefully. Next day I start it and drive it up the road and noticed when reaching 2300 RPM the tach jumped to 5K. So i tried it again and it jumped again and then shut down with a smell of burnt fuse. Sure enough the fuel pump fuse was gone. Drove it slowly home after switching with a good fuse. I changed the pump relays still the same. I remembered years ago a tach jump problem with the cdi box. I changed it with a spare and drive a bit. All good until it warmed up then the tach jumps again starting as low as 1200 rpm. Let it sit overnight , drive it and revs up to 4-5K again no blown fuses and tach steady until warm. Then tach jumps from just about any RPM and can smell slight fuse melt but no complete burn through. I hate to take it to a shop as it is show clean and the shop is driving over 25 miles through a marginal part of town. However my hunch is a bad pump I f so how to safely drain the tank if it is the front pump as I have a hoist in my garage? Has the old CDI box been weakened by what ever is causing this problem?

Last edited by voitureltd; 06-23-2008 at 08:04 PM..
Old 06-22-2008, 03:47 PM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)