View Single Post
fredmeister fredmeister is offline
Smart quod bastardus
 
fredmeister's Avatar
 
Join Date: Oct 2002
Location: Baltimore, MD, USA
Posts: 2,229
Garage
high idle speed after warm up

Hey,
I have a 79 930 turbo with a problem that just started recently.
The car starts fine and idles from cold at 1000rpm. As I let it warm up and blip the throttle, the idle speed gradually increases to 1800rpm or so and will not drop back to normal 1000rpm.
Eventually after a drive on the highway and fully warmed up it will not idle below 2000rpm. I noticed this happening only after driving for a few hours on the highway and comming off the off-ramp the car would not idle below 2000rpm last week.
Now the throttle pedal is not hanging up as it returns to the end stop fine. I have not gone under the car to see if the thottle cable, bell crank is hanging up, but I don't think this is the issue.
Anyone have ideas on the cause? What should I check? I have a DE event coming up next week that I need to fix this right away or I am screwed.
__________________
1979 930 Turbo....3.4L, 7.5to1 comp, SC cams, B&B intercooler, Snow Perf water/meth injection, Rarlyl8 headers, Garret GTX turbo, 36mm ported intakes, Innovate Auxbox/LM-1, custom Manually Adjustable wastegate housing (0.8-1.1bar),--running 0.7bar max
---"When you're racing it's life! Anything else either before or after, is just waiting"
Old 07-18-2008, 08:32 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)