Thread: LC-1 installed
View Single Post
jwasbury jwasbury is offline
beancounter
 
jwasbury's Avatar
 
Join Date: Jan 2008
Location: Weehawken, NJ
Posts: 3,283
Driveability issues solved!

FINALLY!

In this thread (and a few others) I've discussed my part-throttle stumble/miss issue. I was pretty certain it was a fueling problem and I pulled the injectors and followed Billjam's thread on cleaning them. I wasn't happy with the spray pattern at lower pressures, so I decided to bite the bullet and replace them. Well, $600 later my problem was still there.

With things checking out (or replaced with new) on the fuel side, I had to turn my thoughts to ignition. I finally got myself a timing light and found that the timing was too far advanced...fixed the problem and she runs sweet. It seems that the nut holding the distributor had loosened and my timing was drifting.

I could have saved a lot of time and $$ if I had bought the damn timing light first! Anyway, lesson learned. With all the CIS horror stories I read here, I guess I wanted to believe it was something more complicated that a loose distributor nut. I also felt that the ignition system was ok since the car continued to run great at WOT and full boost. Anyway, for the next person who has this problem: don't assume its a fueling issue.

Case closed. Now I can get back to regularly scheduled mods and upgrades Gratuitous 930 pic:

__________________
Jacob
Current: 1983 911 GT4 Race Car / 1999 Spec Miata / 2000 MB SL500 / 1998 MB E300TD / 1998 BMW R1100RT / 2016 KTM Duke 690
Past: 2009 997 Turbo Cab / 1979 930
Old 10-20-2008, 06:39 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #23 (permalink)