Thread: Boost Issue
View Single Post
Dave 86 930 Fl Dave 86 930 Fl is offline
River Rat
 
Dave 86 930 Fl's Avatar
 
Join Date: Dec 2005
Location: 1000 Islands NY
Posts: 405
Thanks for the replies.

The o2 sensor is long gone, it was disconnected many mods ago. I do have an AFR gauge on the car and it appears to be functioning properly.

The symptoms began immediately after the overfill and the only component that I removed from the engine was the airbox in order to clean it. So, I'm assuming that the pressure side of the intake path is properly sealed up, as I did not disassemble any of the components. I did carefully clean off the air sensor plate. After cleaning the oil up the AFR's still were in the low 10's at idle and the car would hesitate badly under boost.

After having these problems at the track, I brought the car home and changed the spark plugs. During the process, I found a broken head stud (crap). So I purchased some new head studs from our very own Henry S. and pulled the motor. The condition of the motor's internals were perfect (40k miles) and most importantly, the pistons looked great ... no detonation. So, the motor is back together and running exactly as it did before the head stud fix ... low AFR's at idle and hesitating under boost.

I'm going to remove the mixture control unit (air flow sensor and fuel distributor) from the motor and give it a good cleaning to remove any oil residue that may be impacting the function of the air flow sensor. I'm thinking that oil may be on the air flow sensor and causing the plate to be lower than it should be, hence causing a rich condition. I'm also going to remove the WUR in order to inspect the vacuum port for oil contamination.

I keep going back to the origin of this problem, I overfilled the oil and it was sucked up into the intake. The oil entered the air flow sensor and this caused the AFR at idle to go down into the 10ís and the motor was missing under boost. Iím not sure how far the oil traveled up the intake path, but it may have made it to the WUR.

Does anyone have any opinion on the effects of oil on the turbo ... can this cause a problem with the seals in the turbo?

I'm working the problem (track day scheduled in 12 days) and I appreciate the responses.

Regards, Dave
__________________
1986 930 - K27-7200, Andial Intercooler, Tial Wastegate, Electronic Boost Controller, B&B headers, Bodart Zork, Leask Adjustable WUR, Full Elephant Racing Suspension w/Adustable Spring Plates and Von Shocks, Wevo Transmission Mounts, Fuel Safe Fuel Cell, Forgelines (9"/11"), Hargett Shifter, Innovate AFR, Cobra CF Seats, DAS Rollbar, Coleman Floating Rotors, Lightweight Interior, Forgeline 17" x 9"/11", 2800 lbs.
Old 10-28-2008, 03:35 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)