View Single Post
beepbeep beepbeep is offline
Registered User
 
beepbeep's Avatar
 
Join Date: Jun 2001
Location: Sweden
Posts: 5,634
OK, that's some more info.

If I understand this correctly, you used 930 3.0L non-intercooled turbo, CIS and intake and bolted this onto N/A 3.0L SC engine?? Which engine and what compression?



First: CIS works with fairly high system pressure. When used with turbocharger fuel demand can be quite high, thus 930 needs two pumps in series to satisfy fueling needs. Using a single SC pump (or even worse, a single EFI pump tailored to lower fuel pressure) is probably not safe for anything but mild boost.

Further on, lower wastegate port should be subjected to boos pressure. Top portion can be left open to atmosphere. Stock wastegate spring usually defaults to 0.7 bar of boost.

I would start with adding second fuel pump, in order to have fuel delivery squared off. Then I would check for boost leaks (check plastic intake spacers for cracks and leaks). After that is done, I would do a dyno run or a pull with WBO2 logger in order to check for leaning or overrich condition (if there is a boost leak present).

If AFR's are OK and engine still keeps cutting out, I would check the ignition (beggnining with plugs and coil). Also, depending on C/R used, you might want to lower a boost a tad...

Regards,
__________________
Thank you for your time,
Old 01-25-2009, 06:04 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #27 (permalink)