View Single Post
cl8ton cl8ton is offline
Registered User
 
cl8ton's Avatar
 
Join Date: Aug 2007
Location: The Golden State
Posts: 1,533
Engine Install, Do you need to prime the scavenger pump?

First, the turbo, scavenger pump, drip tank and oil lines are all stock and were not removed during the drop, the engine has 40k (original) miles on it and did not have the issue prior to the engine drop I am about to describe.

I dropped the engine 2 months ago for light maint work, after installing and starting it up and letting it run all looks fine with no oil leaks.

After cool down there is about 1/3 coffee cup of oil right under the turbo drip tank, I followed the oil trail and it starts at the gasket at the bottom of the drip tank tube under the turbo and runs down the tube to the tank where it then drips onto the garage floor.

I obviously thought it was the gasket between the drip tank tube that bolts to the underside of the turbo so I went about removing the allen bolts and replace with a new gasket.

After getting the 2 bolts out a lot of oil started spilling out from the opening of the drip tank tube?
As if the scavenger pump was not removing (sucking) the oil out of the drip tank and returning it to the main oil tank.

Anyone have any input to what’s going on here?

(I hope this is not one of them, “Gee I never heard of that before, let me know how it turns out” type of problems that I am famous for )

Thanks in advance, you all are a great resource!
__________________
Rod...
2010 - 997 PDK, Black on Black, Daily driver.
1987 - 930 Grand Prix White, Not looking for crazy HP, just harmony!

Last edited by cl8ton; 02-13-2009 at 09:27 PM..
Old 02-13-2009, 06:11 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)