Thread: Super rich!
View Single Post
mark houghton mark houghton is offline
Registered User
 
mark houghton's Avatar
 
Join Date: Jul 2008
Location: Central Washington State
Posts: 3,776
Quote:
Originally Posted by jly535 View Post
Mark it's not intercooled 77', seemed to run out fine when the weather was warm, but once it got cold it went way rich. I would have figured it would run better in the cold weather as the air is denser.

I guess i'll do some checking of the pressures, but I see a digital WUR in my future. Kinda sucked not being able to keep up with the M3's.
Probably just a coincidence that it started running rich when it got cold ouside. Something else is obviously haywire.

Do you have power to the electrical plug-in to the WUR (I think the fuel pumps have to be running in order to read any voltage there). Start her up, unplug the connector and check the voltage. Loss of voltage would not allow the WUR to heat up properly and it would stay in a richer cold start mode with lower control pressures. I would definitely start your diagnostics at the WUR. If control pressures check out, then look at the cold start thermotime switch and injector. The 77's don't have any emmissions crap (like a Lambda O2 sensor system) do they?

Ran my '87 up the canyon Saturday morning, probably 35 degrees out max. Crammed a lot of cold air in there and just went like a bat out of hades.
__________________
Mark H. 1987 930, GP White, Wevo shifter, Borla exhaust, stock everything else. The result of a massive Pelicanite good will fire recovery effort. Truely an open book, ready for the slippery slopes to modification.
Old 10-12-2009, 12:47 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)