View Single Post
kolies kolies is offline
Registered User
 
Join Date: Jul 2004
Location: Berkley, MI
Posts: 261
Garage
New 77 engine rebuild question

I just got my 77 turbo engine back from being rebuilt and installed into the original car. Engine was completely apart when I bought the car. It has been rebuilt pretty much to stock, except for new stainless headers and heat exchangers. Everything was checked, and the distributor, WUR, Fuel distributor were rebuilt.

I have driven it about 4-500 miles. There are a couple of issues that I am seeing when the car warms up:

- Hunting idle - When the car is cold, the idle is very consistent, about 1000 RPM, dependent on where the manual throttle is set. When the car has warmed up though, the idle hunts up and down. I looked at other threads for related issues, and it sounded like the CIS might be a little rich at idle. It all the other inquiries were for '78 or later. Would this be the same issue for the '77?

- Stalling at light - After the car is warm, when I decelerate coming to a light, the engine will consistently stall when i get to the light to stop, unless I blip the throttle, and then it will idle. It will not be a consistent idle, it will hunt as mentioned above.

- Major hesitation - I was driving the car this weekend for the last time this season. I was driving on th highway with moderate acceleration at about 75 in third. I had a hesitation that felt like it lost power and came right back. Don't know how else to explain it.

Any thoughts or ideas on the items above would be greatly appreciated.

Karsten

Last edited by kolies; 11-30-2009 at 03:18 AM.. Reason: Change title
Old 11-29-2009, 04:45 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)