View Single Post
willtel willtel is offline
Registered User
 
Join Date: Feb 2008
Location: Marietta GA
Posts: 2,542
Is my clutch slipping?

When I recently rebuilt my transmission I replaced my clutch, pressure plate, and flywheel at the same time. The flywheel is stock and the clutch is a KEP organic, the pressure plate is a KEP lightened unit. When I first got my car put back together I didn't get the best adjustment on the clutch and it started obviously slipping under high load in second and third gears, I then re-adjusted the clutch and it seemed to hook up great but now I am starting to have my doubts again.

If I hammer it in second it sometimes feels like it takes a long time to run through the gear and the acceleration doesn't exactly blow me away. Other times it seems ok and it has even spun the tires in second after the adjustment although it was very cold and the road was dusty.

I know you guys won't be able to tell without riding in the car but I guess my question is did I ruin my clutch disk when it was slipping due to poor adjustment? If so what do think it is likely that I have damaged the other parts as well?

If it isn't wet tomorrow I will see if I can get a video to help illustrate what I am feeling.

Any opinions are welcome. The car makes about 400hp at the crank, the tires and gearing are stock.
__________________
1987 GP White 930
1977 Ford Bronco

Last edited by willtel; 12-30-2009 at 04:30 PM..
Old 12-30-2009, 04:20 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)