View Single Post
djdawson2 djdawson2 is offline
Registered User
 
Join Date: May 2009
Location: Evergreen, CO
Posts: 231
Send a message via Skype™ to djdawson2
Quote:
Originally Posted by JFairman View Post

I have had an intemittent problem with the fuel pumps shutting off randomly in my car since I bought it....

I've jumped both red relays in the front and the yellow relay in the rear and they still wouldn't run and then they'd just come back on when they feel like it....

I thought the speed relay only cut out the ignition around 7200 rpm but it's also tied into the fuel pump circuit. If you remove either of the 2 white wires, or the red wire, or the brown ground wire from this speed relay the fuel pumps shut off.

I accidentally found that if I tapped this relay while the pumps were running my fuel pumps would shut off or come back on intermittently... great.

hope this helps.
Not to highjack this thread... but this is AWESOME news! Your symptoms are exactly the same as what happens in my '89. I'll be driving along... everything is A-OK, and suddenly she quits... no pumps running. I have fooled with the red relays, the yellow relay, and the air sensor plug to no avail. I have been considering rewiring direct with an impact (crash) relay as the only protection, since there is nothing more annoying that a sudden shut-down.

Interesting note is that when it does shut down, hitting a bump often brings it back to life. Also, when it dies out, it also typically restarts after a few attempts, so I have not been left stranded... yet. However, this is an EXTREMELY annoying problem! I know what I'll be checking this weekend.

Thanks JF... appreciated.
Old 03-23-2010, 04:49 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #44 (permalink)