Thread: Odd AFR issue
View Single Post
87 930 87 930 is offline
Registered User
 
Join Date: Nov 2007
Location: Hesperia, Ca.
Posts: 156
Garage
Odd AFR

Mark: I run the same idle mixture AFRs as you do and my '87 has the exact same symptoms. I believe that they're all related to IC heat soak.

My theory is that the idle drops because the IC has heated the intake air causing a slightly too rich mixture (yours stutters and pops which does sound like lean; mine doesn't). The improperly rich idle mixture lowers the idle speed which raises the airflow sensor a bit to lower idle a bit more. Because of this low idle speed , ALOT more outside air crawls up my RarlyL8 straight-thru muffler and hits my wide band O2 sensor and relays the same lean AFRs that you have.

Once I get the rpms up and the engine fan pulls some heat off of the IC, all these symptoms disappear. I just raise the idle speed with my foot for 30 seconds or just drive off and cool the IC with passing air. End of issue, idles normally.

BTW, my Leask WUR is two years old (works great) and all of my fuel pressures are nominal. I agree with the others about richening our idle AFRs and have been meaning to do so.
__________________
Scott - 1987 930: 3.45L Supertec engine w/GT3 crank, California Motor Sports upgraded 930 trans, modified suspension, Zuffenhaus 9's and 11's, black on black..."The Black (Financial) Hole"
Old 04-06-2010, 10:18 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #8 (permalink)