View Single Post
boosted 89 boosted 89 is offline
Registered User
 
boosted 89's Avatar
 
Join Date: Nov 2009
Location: Ontario Canada
Posts: 132
Garage
frustration mounting

Hey All

Yes I'm still trying to get the 930 to pass emissions here in Ontario Canada. I've adjusted the CO screw down to the point where my wibeband o2 sensor says I'm running 15.2 afr at idle. Its passes the idle test with 0.02 reading but during the 25mph test it fails miserably with 2.95%CO output. It doesn't have the air injection pump any more(not sure if this is the reason why its failing) and the 3rd last time I tested it, the car ran a 0.72 CO%(which still fails, but is the closest I've been to the 0.33% required) at 25mph but failed with a 2.91CO% at idle. I was using my WB output for a lambda signal but later found out a fault with an output of only 0.032volts at 14.7 afr. Tried an aftermaket O2 (narrowband) and got a 0.455 volt output at the same afr which I used for the lambda signal and it still failed with a 2.95%CO...but passed at idle. I guess what I'm asking is...what does the O2 signal act on to adjust the afr to 14.7 during the idle and lower rpm/loads. does it signal the WUR using the bimetal strip to adjust the control pressures..is there a lambda module of some sort. I've been screwing around with this thing and it seems like I take one step forward then 3 steps back. All my CO adjustments are done at N.O.T and before the cat through the O2 sensor hole. If my afr's are 15.0/1 before the cat then I would think it would at least be close to passing.

Any input would be greaetly appreciated

Chris

it may very well end up at a Porsche dealer if I can't get this resolved..i'm just to anxious to drive it!
Old 05-28-2010, 04:15 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)