View Single Post
slyguy slyguy is offline
Registered
 
Join Date: Sep 2004
Location: Tonawanda NY
Posts: 793
Quote:
Originally Posted by mark houghton View Post
It's the reverse of what you would think....unplug the thing and the pumps will run continuously with the key on (that is, if you're referring to the green - or is it blue - plug behind the metering plate near the top of the fuel distributor).

Slyguy, did you forget to connect the single wire to the overboost pressure sensor on the boost recirc manifold? That wire must be grounded (through the normally closed sensor switch) for your pumps to run. And what's this test relay you refer to? Replaces the yellow troublemaker?

I presume you've checked the fuel pump fuse up front in the fuse tray?
I absolutely love the fact you guys are up later than I am surfing the pelican site!!! (time zones notwithstanding of course...)

Fuel pump fuses fine, did the Rice mod some time back...
Overboost switch has no effect plugged in or unplugged...
overboost pressure sensor grounded as it has always been...

My test relay is simply one with the cap removed allowing you to manually power it up, very handy to have around!



__________________
82 930 Pearl White 3.3 964 cams, K27 HF, Kokeln, fuel enriched, IA fuel head mod, wur mod, crankfire, 2X plug, Aase worked heads. 1bar, GHL, zork, 23/33 bars, low, loud

Last edited by slyguy; 06-14-2010 at 12:09 PM..
Old 06-14-2010, 12:06 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)