View Single Post
smurfbus smurfbus is offline
Turbofrog
 
smurfbus's Avatar
 
Join Date: Aug 2009
Location: Europe
Posts: 1,384
Fuel system cleaner used, no help

Measured fuel pressures:
System 6.35bar
warm was 3 bar raised to 3.4 bar
enrichment 1.2bar (remember, I dialed max fueling) and still lean!

Fuel delivery on the wur line only 147g/min (147 equals only 109ml )? Spec is 160ml-240ml IIRC
What is the best way to measure fuel pump delivery? Fuel return line as per manual? Spec is 1170cc in 30 seconds

EDIT: Ok, measured the fuel delivery on the return line and it was only 1liter per 30sec, spec being 1.170 L. Then I tried to measure the pressure between the pumps but the CIS kit from pelican does not have AN adapters so I desided to try my spare 044 at the rear. But no go here either as the 044 has 18m*1.5 threads and the bosch that was at the rear was much smaller dia. Freeeck. At this point I was already loosing vision (gas fumes) so I had to quit.

So hopefully I find some adapters today so I can try the 044 which is half way installed already. If it does not help then I will measure the pressure between the pumps if I find a adapter for AN to CIS-kit fittings. That should tell if the front pump is Ok.

Checking fuel pumps from manual:
Pressure between pumps must be between
2 and 4 bar. If less than 2 bar, the first pump
(front) is defective. If more than 4 bar, the
second pump (rear) is defective. Replace
defective pumps and recheck pressure.

Last edited by smurfbus; 06-17-2010 at 09:36 PM.. Reason: Fuel delivery info added
Old 06-16-2010, 10:52 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #31 (permalink)