View Single Post
mark houghton mark houghton is offline
Registered User
 
mark houghton's Avatar
 
Join Date: Jul 2008
Location: Central Washington State
Posts: 3,776
Quote:
Originally Posted by A930Rocket View Post
I have to do a reach around to get mine to pop up while pulling on it. Maybe it needs lube or something? When it does pop up, I need assistance from a prop rod. Oh! the days when my shocks were young and spry...
A simple adjustment to the spring tension on the latch post should solve that. Just screw in the shaft that runs through the spring to put more pre-load on the tension. Then when you pull the latch cable the lid should pop up with more authority.

A word of caution: Make sure the shaft isn't bent, which will cause the tension to load off-center in the latch...and may hang up and not release when you pull the cable. Been there, done that when I first attemted to adjust things back there. Couldn't get the lid to open at all, and there is no way to get to the latch to force it open in such an emergency. You're basically f - - ed if that happens. You have to resort to giving the lid a bear-hug and wrestling it sideways/up and down/round and round with all your might to get the lid open again.
__________________
Mark H. 1987 930, GP White, Wevo shifter, Borla exhaust, stock everything else. The result of a massive Pelicanite good will fire recovery effort. Truely an open book, ready for the slippery slopes to modification.
Old 06-18-2010, 11:18 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #7 (permalink)