View Single Post
Tippy Tippy is offline
Chain fence eating turbo
 
Join Date: Dec 2008
Location: Austin, TX
Posts: 8,422
Quote:
Originally Posted by 930gt-40r View Post
Personally, I would have the t-4 flang cut off and have a divided t-4 flange fit to it. Then with the divided flange, throw a divided hot housing on the turbo or go for one that does. I don't understand why the boost comes in so late with that tiny exhaust housing on there- maybe the turbo is tired? And the waste get system may be a bit too long- I had the same creeping issue with my old setup and it was due to a long waste gate circut along with improper placement...
You think the housing is too small? It is roughly 2 inches smaller I believe than the compressor. You think the WG circuit is really killing it?

Quote:
Originally Posted by drmatera View Post
A T4 .81 housing on a stock 3.2 would be very laggy. That turbo looks like it ate a chain link fence, does it smoke or have any shaft play?
The .81 I thought is the reason for the severe lag but 930gt-40r thinks it's too small?!?! Yes, the turbo shaft is very sloppy (it did not have a BOV) and it must have not had a filter for awhile .
__________________
Cory - turbo'd '87 C3.2 Guards/Blk, 3.4, 7.5:1 CR P & C's, soon to be 993SS cams and GSXR 750 ITB's fed by 964 intake, Borg-Warner S366 turbo @ 1.4 bar, Treadstone full bay IC, TiAL F46 WG, HKS 1 1/2" BOV, twin 044 pumps, MegaSquirt 2 (v3.57 board) w/EDIS, Tramont wheels (285's rr, 225's frt), Big Reds frt, 993 rr., tower brace, MOMO wheel
Old 08-10-2010, 08:04 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)