View Single Post
jwasbury jwasbury is offline
beancounter
 
jwasbury's Avatar
 
Join Date: Jan 2008
Location: Weehawken, NJ
Posts: 3,597
I'm going to make a guess that its ignition related. This is only because when I had a miss at light throttle (none on boost or at idle), I first assumed intake leak, then fuel and chased those things for months. After replacing all seals, testing WUR and checking fuel pressure, and replacing injectors ($$$), the problem persisted. Only then did I buy a timing light and checked spark timing. Way way off...too far advanced. The distributor hold-down nut wasn't tight and the dizzy had 'walked' off time. I was happy to find the problem, but shocked at what it turned out to be. I thought with the timing set so advanced, I'd have experienced symptoms on boost, but the car ran great under every scenario except light throttle cruise.

The lesson I learned is that I should go through the basic "tune up" list any time I have an issue. Had I checked off all the items on that list before zeroing in on a fuel injector problem, would have saved myself $600 on new ones. I suppose I have a spare set now though (for the day they are NLA). Maybe you and your mech have already gone through all of this? How are your plugs? Wires? Cap/rotor? Green trigger wire from dizzy to CDI? Do you know anyone that you can swap CDI boxes with to rule that out?
__________________
Jacob
Current: 1983 911 GT4 Race Car / 1999 Spec Miata / 2000 MB SL500 / 1998 MB E300TD / 1998 BMW R1100RT / 2016 KTM Duke 690
Past: 2009 997 Turbo Cab / 1979 930
Old 09-18-2010, 06:52 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)