View Single Post
krasuskyp krasuskyp is offline
Large Member
 
krasuskyp's Avatar
 
Join Date: Nov 2001
Location: top of 3rd
Posts: 4,229
Garage
keep blowing fuel pump fueses - help?

Out of nowhere last week, I fried the 25A FP fuse in the front block. I mean, really fried it - the red wire going into it looks charred somewhat.

Replaced it, parked it. Was nearly out of gas at the time, hoped that 'may' have caused it?

10gal in this morning, 15mi into a really nice run - POOF - over I go again. Replaced it, got maybe a mile, POOF again. Towed it home. Awesome.

The replacement I put in had melted and the wire is more charred. The block in the engine compartment has the middle fuse looking 'somewhat' corroded, and the red wire into it has nominal blackening.

Is one of my FP's on the way out (at 50k miles!?)? Relay on way out? Shorting out somewhere else? Car's unfort been parked outside all summer/fall, def took it's toll on corroding that rear fuse block - yay.

Please edumucate my ignoramus on how to proceed w/ the troubleshootage.

Figures, too - the famous "last run of the season" syndrome. Parked until spring, sigh. I'll get to it some winter's eve...

TIA gentz.
__________________
Paul... CT | '87 930 | '08 M3 6gang vert |
past:

| '07 S6 | '98 M3 vert | '01 M5 | '96 993 C2 cab | '05 S600 Sport - biturbo V12@Just Not Right 495rwhp / 612rwtq |
| '58 TR3A | '01 S8 | '95 S6 6gang | '88 M5 | '87 190E 2.3-16 |
Old 11-12-2010, 01:11 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)