View Single Post
jsveb jsveb is offline
Registered User
 
jsveb's Avatar
 
Join Date: May 2007
Location: Norseman territory
Posts: 2,759
Garage
Car Stalled on me - trouble shooting needed

Hi

Yesterday morning on my way to work the car died on me. It didn't totally die, but it ran only on a couple of CYL, so I decided to shut it off.

I was on my way, and everything was fine, until it started "stuttering". In the beginning it was just like a minor misfire, but it very soon got worse, and within seconds the car sounded really bad, and no power was available.

I have later been told, by the guy behind me, that the exhaust (ZORK) was glowing red (it was dark). I was only travelling at 45 mph, so no "boost glow" from the turbo.

My guess is, it is ignition related.

I have just tried to change the cap and rotor. That didn't change anything.

I popped the lid after shutting the engine off. The one thing that worries me is smoke coming up from the engine. This is not normal, but I am wondering if it was because of the glowing exhaust and maybe a bit of oil and unburnt gas.
It didn't catch fire

Next for me will be to pull the plugs and see what CYL does fire, and if other malfunctions are evident.

I am hoping for advice on my next moves.
__________________
Jesper
Carrera 3.0 1975
930 1978 OEM Matte Schwartz, ANDIAL IC, BL WUR, SC cams. LMA-3 w. XD-16 and CP transducer
www.stauningwhisky.dk
Old 05-06-2011, 08:20 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)