View Single Post
mark houghton mark houghton is offline
Registered User
 
mark houghton's Avatar
 
Join Date: Jul 2008
Location: Central Washington State
Posts: 3,775
Quote:
Originally Posted by wcc View Post
Long story short.... Car went from normal to quit in 15min and towed home. Starts and barely idles with black smoke. I picked up a CIS gauge but it was CIS compatible so I still need that tool. In the meantime I've replace a hose looked at the plugs and will be checking the cap/rotor and replacing the fuel filter and a few other minor things. In the meantime if any of you have any suggestions or comments on some other things to check let me know...

Here's a video of it right before it quit....
So, during your ill fated ride, did you perhaps run at full boost for even a short period...or were you just tooling along being mellow and suddenly $hit happens? Could be several things, but I would follow 911Nut's directions to look first for the obvious vacuum/air leaks. And definitely check your fuel pressures (control and system). BTW. a faulty AAR won't cause your black smokin' crappy running condition in and of itself, unless it's got bad hoses leaking air.
__________________
Mark H. 1987 930, GP White, Wevo shifter, Borla exhaust, stock everything else. The result of a massive Pelicanite good will fire recovery effort. Truely an open book, ready for the slippery slopes to modification.
Old 06-21-2011, 06:53 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)