View Single Post
mark houghton mark houghton is offline
Registered
 
mark houghton's Avatar
 
Join Date: Jul 2008
Location: Central Washington State
Posts: 3,885
That POS relay under the seat....

Just a reminder that if you're having mysterious "she just shut down" or "won't start" symptoms, along with looking at the usual culprits (the yellow relay from hell, the overboost sensor, fuel pump relays....and the like) don't forget that there is the overspeed relay under the drivers seat that ties all this worthless crap together. Mine has been doing the sporadic no start thing, and when fiddling with the relay the pumps would stop...then start...then stop, depending on the position of the relay.

Could be a bad connection (nope, cleaned the piss outa that), could be a bad/broken wire in the bundle (awfully unlikely and equally difficult to find), or could be the relay itself (hopefully not at something like $350).

One more time, I pulled the seat out and took the relay to the workbench to remove the tin and inspect the innards. Looked almost new, no visible oxidation or bad solder joints. But, there are about 8 connection points where the manufacturer used rivets to make electrical connections to tinned metal strips. Unfortunately you can get to only two of them....which I did with some flux and solder to solder those rivets in place. And while had the iron hot, I turned the circuit board over and re-soldered all the remaining points that eventually lead to the socket connection points.

No problems with it since.
__________________
Mark H. 1987 930, GP White, Wevo shifter, Borla exhaust, stock everything else. The result of a massive Pelicanite good will fire recovery effort. Truely an open book, ready for the slippery slopes to modification.
Old 07-13-2011, 04:57 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)