View Single Post
1986911 1986911 is offline
Registered User
 
1986911's Avatar
 
Join Date: Jan 2008
Location: TAMPA
Posts: 547
Garage
Looks like I figured out what was wrong with my car. I changed the fuel pump and thought it was done. I started the car without getting in it and watched with joy as the car warmed up and AFR's were as they should be. I sat inside to turn off the car and restart to see if anything would change. So far so good. I got out to close the bonnet and look one more time for any fuel leaks before heading out on a test run. As soon as I get out, afr's jump back up to 19's and car starts acting up. CRAP. I sit back inside and car goes back to normal. Long story short the large black plug under the driver's seat was loose.



I pulled it out, cleaned it with electrical connection cleaner and adjusted (bent) the tabs on the box where it plugs in. Now its nice and snug. I could pull it off with my hand!

Search is truly your friend, it planted the idea to check and wiggle all connections and relays while trouble shooting.

Well, I got some CIS gauges and a spare rear fuel pump out of it so not too bad.
__________________
MG---1986 911 TARGA, SSI'S, STEVE WONG CHIP, M&K EXHAUST, ELEPHANT RACING GOODIES + TRU DESIGN CUSTOM FUCHS
1989 930 FACTORY SLANT NOSE -- RARLYL8 EXHAUST, K27 7200, TIAL 46MM, 0.9 BAR SPRING, GARRETSON INTERCOOLER , LEASK WUR, WEGO IV AFM AND NHS BOOST GAUGE.
2012 DODGE RAM 3500 LONGHORN 4X4 "EVERYTHING BUT THE KITCHEN SINK"

Last edited by 1986911; 04-16-2012 at 05:09 PM..
Old 04-16-2012, 05:06 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #15 (permalink)