View Single Post
arethusa71 arethusa71 is offline
Registered
 
Join Date: Jun 2001
Location: Carlisle, MA
Posts: 50
Garage
I have been having intermittent problems with my 84 for well over a year. Decided to dig into it deep today. Several mechanics have looked at the problem, swapped a switch here or there.. but no one was able to fix it.

I tested each switch, and I found some of the wiring was wrong/and loose. Validated the wiring, and crimped down the spade connectors to make sure nothing was loose.

I was then able to put the window down, but not up (on passenger side)

swapping the blue wires in the middle of the switch on the passenger side allowed me to put it up but not down.

Looking at the wire layout, i decided that the runners between the switch must be the issue.

I then swapped the red-black and red-white and reversing these allowed me to put the window down or up depending on the position of the wires (hope that makes sense)

Next i did a continuity test on the red-white/red-black wires between the drivers and passenger door. One wire is bad!

Running a jumper wire (just as a test) to replace the red-white wire returned all window switches to normal operation.

Next I need to decide if I am going to replace the red-white wire or try to trace where its broken/damaged. I cant really follow the wire, so probably replacing it is the way to go.

Anyone else need to do this? I assume a mouse munched it someplace
Old 09-12-2012, 05:50 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #41 (permalink)