View Single Post
PrimeMvr PrimeMvr is offline
Registered User
 
PrimeMvr's Avatar
 
Join Date: Dec 2010
Location: Iowa
Posts: 364
Garage
Don't feel too bad Brian, I spent three weeks this summer diagnosing painfully poor running off-idle. Car would start right up, good throttle response in neutral, pull out of the drive and it wouldn't rev over 2500. My troubleshooting went as far as flow testing injectors, and re-checking cam timing, because replacing a cam seal was the last thing I did before the crappy running. I was moments from calling a flat bed too before I decided to do one more back-trace of everything. The culprit? Wait for it.....a rag I stuffed in the turbo inlet while it was apart for the seal rapair!

You just never know with these old girls and, in my case not yours, their weekend mechanics.

For anyone coming across this mea culpa, the lesson is that the problem isn't always where the symptoms lead you. When the engine would puke, the AFR gauge would show really lean, so I was totally focused on the fueling. Restricted airflow makes it lean? Well sure, when the fuel is metered by a barn door flapper.

Glad to hear you'll be burning it up in that beauty soon.
__________________
Steve
87 930 - Black - 3.4L/964 cams/K29/Powerhaus IC/6AL-2/B&B dual exhaust/MTX-L/235-315 Toyo R888/18" Kinesis wheels/Big Red brakes/LSD
10 997.2 Cab - Speed Yellow
83 SC Cab - Guards Red [SOLD]
Old 01-14-2013, 07:00 PM
  Pelican Parts Technical Article Directory    Reply With Quote #477 (permalink)