View Single Post
Ronnie's.930 Ronnie's.930 is offline
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
OK - the O2 sensor is fine so I adjusted the idle mixture screw slightly leaner and the idle cleared up. I have an Innovate LM2 but have yet to install it (will do so in the next couple of days) so this adjustment was done by the seat of my pants. The car idles fine, runs great and pulls hard.

I do have an additional question, however:

While playing around with the idle problem, I noticed that if I hold the throttle between 3-4K, no load/while parked, I can hear some burbling and/or popping from the exhaust. It kind of sounds like deceleration popping when you remove the vacuum limiter valve (as I did years ago) but nowhere near the intensity (very minor). I would almost call this a "misfire" except for the fact that the car runs and drives like it always has. I don't know if this is new or not, as I can't remember the last time I held the throttle in this manner (years ago when I last timed it). I guess I am looking for comments regarding what other people's exhausts sound like in similar circumstances. I have a RarlyL8, non-Hooligan muffler that is about four years old . . .

BTW - when I noticed the "high rev burbling" I experiment with re-richening the idle mixture and there was no difference other than the idle went back to shat . . .

Last edited by Ronnie's.930; 02-09-2013 at 12:59 PM..
Old 02-09-2013, 12:35 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #22 (permalink)