View Single Post
T77911S T77911S is offline
Registered User
 
T77911S's Avatar
 
Join Date: Oct 2006
Location: MYR S.C.
Posts: 13,434
the yellow relay is controled or energized by the AFM switch. with the key on and engine off, the AFM energizes the yellow relay, removing the ground to the 2 FP relays. that ground is of course the boost pressure switch.

here is how i would go about TSing this system: based on whats esiest to do first and each step does not fix it.
(if one pump runs and one does not, then the FP or the relay.)
both pumps not running:
i would reach around and pull the connector off the AFM. as soon as the key is ON, no start needed, the FP's should run.
then i would check to see if the boost pressure switch is grounded. with connector off AFM, ground the wire on the boost switch.
jumper 30 and 87a on yellow relay
jumper pins 1 and 2 on the speed relay
IF 1 and 2 run the pumps, check for 12v to speed relay
if 12v present, speed realy bad. bad solder joints is a problem on this relay.

a note for the yellow relay:
unlike most realys, the yellow relay runs the pump in the de-energized mode. so the coil can be bad and the pumps can run. you might consider popping the cover off and cleaning the contacts with fine sandpaper. i bet there are a LOT of good/repairable yellow relays that have been replaced.

the FP circuit was different for the years on the 930 from what i am told. the 87 has a fuse in the wire bundle itself that feeds power to the speed relay. it is a pain to get to....from what i am told.


fahad
you may have moved a wire that is not making good contact. you could also have a lose or bad contact in the yellow relay socket. you could do as i said abbove, clean the contacts on your old relay.
follow my trouble shooting. start with the AFM switch.
in your case, i might jumper 30 and 87a on the yellow relay socket first. make sure it is in a "no start condition"
__________________
86 930 42kmiles [__] RUNNING:[__] NOT RUNNING: ____77 911S widebody: SOLD
88 BMW 325is 200K+ SOLD
05 BMW 330CI 130K:: [__] RUNNING: [__] NOT RUNNING:
08 VOLVO V70 190K:: [__] RUNNING: [__] NOT RUNNING:
90 B2200[__] RUNNING:[] NOT RUNNING:__2000 MER E320 WAGON [] WRECKED:[]RUNNING:
Old 04-18-2013, 09:39 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #9 (permalink)