View Single Post
gavinc69 gavinc69 is offline
Registered User
 
gavinc69's Avatar
 
Join Date: Jul 2008
Location: Bournemouth UK
Posts: 996
Garage
Sorry for the long delay Uncle.
I've been away all weekend but I did manage to get several hours on the car tonight.

The new TurboWerx pump is installed and works well. It is basically silent

I temporarily cable tied the intake charge pipes together and made a small bracket to help hold them tight.
This has now greatly reduced the drumming noise I had when on boost.

Just need to make up a more permanent solution to secure the pipes

I'm finally getting to enjoy the booooooossstt with out thinking the engine will blow.

Lastly there is still lots of vapour from the oil tank when you take the filler cap off when the engine is hot.
I think having a catch can fitted for the tank means its always going to fill up quickly due to the vapour condensing.
I will try bypassing the catch can and just use a filter on the breather port take off from the filler neck. See how that works.

Glad to get some good progress as I want to drive the car to Goodwood Festival Of Speed on the 14th and Silverstone Classic on the 21st

Hows things your end Uncle?
__________________
1980 SC Flatnose, Euro 3.0, LW Flywheel, 993 Cams, Port & Polish Heads, RS Cut Valves, MSD 6AL, Blaster Coil, Magnacor Leads, Boxster Brakes, WEVO Mounts, TRG Roll Bars, Rollcage, RSR rear fenders, OE Short Sift, K27 7200 Turbo Conversion, OBX Headers, Tial Wastegate, EFI MicroSquirt v3

Last edited by gavinc69; 07-01-2013 at 02:45 PM..
Old 07-01-2013, 02:42 PM
  Pelican Parts Technical Article Directory    Reply With Quote #167 (permalink)