View Single Post
unclebilly unclebilly is offline
aka 'vageen'
 
unclebilly's Avatar
 
Join Date: Nov 2003
Location: Calgary, Alberta
Posts: 4,094
Garage
Oil leak - turbo vent line?

I have searched and think the scavenge pump could be my problem... Maybe my turbo is shot?

So here is what I have...

86 Euro 930
Garretson Intrcooler
K27 turbo
Cams...

A year ago I was under boost and noticed a big cloud of smoke behind me so I pulled over to discover oil everywhere.

I initially thought the problem was my turbo oil line. I fixed it and the problem persisted. I replaced the turbo oil line, cleaned everything up really well and then the car had a massive vaccuum leak so I parked it and enjoyed my 76 for the summer.

I recently fixed the vaccuum leak (torn o-ring on the throttle body) and got it back together. It runs great but the turbo tank oil vent line is puking oil out under boost. If I drive the car like an old lady and keep it under .2 bar, it doesn't loose any oil (I am also keeping it under 2500 rpm). My vent hose terminated up by the deck lid hinge and has a 1" K&N filter on it.

Why did this happen all the sudden?

Here are my thoughts on what could possibly the issue...

1. Turbo seals are shot.
2. Scavenge pump drive pin broke.
3. When I changed out the turbo oil line, the 9mm ball didn't go back in... I know I put it back in there...
4. Maybe the turbo oil line wasnt the culprit initially and only had a small leak...
5. Coked up oil line between scavenge pump and tank...

What are your thoughts? How can I figure out what to tear into first?
__________________
76 930 - featured in Sept 2013 Pano
77 911S Wide Body GT2 WCMA race car
86 930 Slantnose - featured in Mar-Apr 2016 Classic Porsche
Yoosta have: 90 C4 Targa, 87 944, 73 911 ChumpCar endurance racer - featured in May-June & July-Aug 2016 Classic Porsche

Last edited by unclebilly; 05-13-2014 at 10:35 PM..
Old 05-13-2014, 09:09 PM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)