View Single Post
T77911S T77911S is offline
Registered User
 
T77911S's Avatar
 
Join Date: Oct 2006
Location: MYR S.C.
Posts: 13,546
the MSD shoud not cause any problems. if anything it has made a problem you already have known. clean the battery posts, both neg and pos. clean the ground strap to the body. clean the strap from body to tranny. clean the connections at the starter.

check fp current
remove the FP fuse. set your meter to measure current. connect the meter in place of the fuse. leads dont matter, it will just read negor pos. pull one of the FP relays. remove the connector on the top rear of the AFM and turn the key on. read current and turn key off. swap relays and repeat. dont leave the pump on any longer than you have to.
current should be around 7 amps for each pump.

measure voltage at pumps.

another thing you can do is to remove the wires at the fuse block for the FP. clean the wire ends and clean the screw. clean the contacts for the fuse. you can also split the FPs to 2 fuses. i did it so that mine looks orginal. if you want the way i did it let me know.

if all is good i would not worry. the Fp in my 77s made lots of noise the entire 10yrs i owned it.
__________________
86 930 42kmiles [__] RUNNING:[__] NOT RUNNING: ____77 911S widebody: SOLD
88 BMW 325is 200K+ SOLD
05 BMW 330CI 130K:: [__] RUNNING: [__] NOT RUNNING:
08 VOLVO V70 190K:: [__] RUNNING: [__] NOT RUNNING:
90 B2200[__] RUNNING:[] NOT RUNNING:__2000 MER E320 WAGON [] WRECKED:[]RUNNING:
Old 11-04-2014, 04:01 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #13 (permalink)