View Single Post
Rich76_911s Rich76_911s is offline
Work in Progress
 
Rich76_911s's Avatar
 
Join Date: Jun 2004
Location: Ardmore, PA
Posts: 3,159
Garage
Quote:
Originally Posted by T77911S View Post
i would not spend the $ on a FPR. do some more testing before spending $. if 6.75 is spec, the FPR is working.

first, how do you know you are running rich? do you have something to test the exhaust?
second, if that is what brian set your WUR to find out what system pressure that is based on.
(probably not that big a deal. most likely it was set for your system pressure spec).
then i might try another set of gauges. i have 2 sets, both bought at the same time. they read nearly 1bar different but on the hi end, IE system pressure. one set says 5.3bar the other says 6.1bar.

i dont know what that particular solenoid is for but there were ones on there for blocking vacuum to the dist, like when under boost.

i take it these pressures are checked with the engine off since you say it wont start.
I thought I was rich before I sent the WUR off to BL because I was getting choked out under partial boost and was leaving a black cloud behind me when it happened. Gas mileage was down near or below 10 mpg as well.

When I installed the BL WUR I also installed a PLX wideband O2 sensor and gauge. I felt it was best to be able to have knowledge of my AFR's with an adjustable WUR. The gauge only measures down to 10:1 and I spent significant time there, so I can confirm my gut feeling that I was rich.

Yes pressures were measured with the car not running. And I do confess that it was not on a battery charger for the measurement.

Thanks again everyone for your thoughts and input.
__________________
"The reason most people give up is because they look at how far they have to go, not how far they have come." -Bruce Anderson via FB
-Marine Blue '87 930
Old 11-17-2014, 12:06 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #11 (permalink)