Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > 1- Porsche Technical Forums > 911 / 930 Turbo & Super Charging Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Mar 2007
Location: South Africa
Posts: 17
Porsche 930 Turbo boost sensor

Hi Guys

I have a 930 turbo vehicle and was wandering if someone could explain the following.When the vehicle is started the boost guage automatically goes to 1.5 Is there something wrong with the sensor or could it be behind the instrument cluster.

Kindly Advise

Thanks

Adrian
Old 04-01-2007, 09:28 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
youngkang's Avatar
 
Join Date: May 2004
Location: Edmonds, WA
Posts: 128
Garage
Most likely a sensor issue. Just get a after market mechanical gauge and don't bother with stock one. They are known to be inaccurate.
__________________
86' 930 red "Wild @ss Hotrod" Thanks John
Old 04-01-2007, 09:57 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Gotta Jibboo
 
BSiple's Avatar
 
Join Date: Feb 2002
Location: Fort Collins Colorado
Posts: 4,955
Garage
Send a message via AIM to BSiple
When my overboost sensor was grounded out, my boost gauge read .7bar (the highest the digital gauge in the 964T car's reads) all the time. When I hooked the overboost up correctly, the guague began to operate normally.

Not sure if that could be the case in your car.

Bill
__________________
2003 996TT
1992 964 Turbo (sold) Holy crap are these expensive now!
1986 911 Cabriolet (sold)

I don't know why I do the hillbilly things I do.
Old 04-01-2007, 12:25 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered User
 
2369488's Avatar
 
Join Date: Jan 2007
Location: Wichita
Posts: 81
boost sensor

I had the same issue. Althought mine reads anywhere from .2 to .7 on start up. I have an aftermarket 3" VDO boost gauge that is vacuum and it is very accurate. However, I am having my mechanic look at it any way.
Old 04-02-2007, 10:48 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 08:12 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.