Pelican Parts Forums

Pelican Parts Forums (http://forums.pelicanparts.com/)
-   911 / 930 Turbo & Super Charging Forum (http://forums.pelicanparts.com/911-930-turbo-super-charging-forum/)
-   -   Yep, its another CIS thread (http://forums.pelicanparts.com/911-930-turbo-super-charging-forum/422541-yep-its-another-cis-thread.html)

jwasbury 07-29-2008 08:23 PM

Yep, its another CIS thread
 
Ok...I'm finally getting down to chasing down some issues with my car that I believe are fuel related.

Here are the symptoms:

Part throttle stumble/miss. This has been going on practically since I bought it in Nov, but I think may be getting worse. Only seems to happen under load. If I stomp on it, all is well and she runs like a bat out of hell. Very happy on boost, with no noticeable smoking. Idles steady when warm, no hunting. But if I'm giving it just a C-hair of throttle, its stumbling and running rough. This is most noticable at highway cruise speeds. Its hard to maintain a steady cruise in top gear on a flat or slight decline. Going uphill(even a slight incline), to maintain constant speed, I have to use a bit more throttle and she's fine. On the flats and declines, she's missing at best, and at worse it can be a small bucking.

Cold start problems. This is fairly new...last month or two. Cold starts she will idle high for a few second on the first start, but then the rpms drop and she won't idle and dies or will idle very low until warmed up.

Warm start problems. Also fairly new...started same time as cold start problems I think...last couple months (since its been warm maybe?). Repeated cranking to get the engine to fire after its been sitting for a while. Immediate restarts not a problem. It mostly seems to happen after the car has sat for an hour or two after running when ambient temps are fairly high (70-80s).

Here's what I've done so far:

Replaced fuel filter. Checked fuel pressures. System pressure is good at 6.5 bar. Cold control pressure seems high at 2.8 bar (30 degress celcius). Warm control pressure seems ok at 3.7 bar (this was using the electric heating only...did not run the engine). After shutting down the pumps, the pressure held at 1.5 bar for over 20 minutes.

FYI the WUR is Bosch # 438 140 054 and appears to be correct for this application. Its also pretty new. Both it and the accumulator were replaced by PO within the last 5 yrs and less than 10k miles.

I think I need to adjust the cold control pressure. Maybe that will fix my warm and cold start problems Then what? The off idle stumble is pretty annoying and I really want to get that sorted.

NathanUK 07-30-2008 09:57 AM

Sounds like you need an AFR setup. Innovate is very good.


All times are GMT -8. The time now is 06:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website


DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.