Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > Porsche Forums > 911 / 930 Turbo & Super Charging Forum


Reply
 
LinkBack Thread Tools Rating: Thread Rating: 1 votes, 1.00 average.
Author
Thread Post New Thread    Reply
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
Innovate LM-2 @$%#&

I guess I shouldn't have waited 4 years to try out my LM-2 purchased from Pelican back in August of 2008-the damn thing doesn't work! It just throws an E2 error code (open heater circuit) right after it powers up. None of the troubleshooting steps have worked so I've sent an email to their tech department. I did some searches and found that this is a common problem with those units and that I shouldn't expect much help from Innovate (can't expect much, I guess, since I bought the thing eons ago and let it sit in a box like a dumb ass). Like JimTweet would say WTFer MFer SOB!!!!!!!!!


Last edited by Ronnie's.930; 02-09-2013 at 06:06 PM..
Old 02-09-2013, 06:03 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered
 
Join Date: Jan 2008
Location: sunny buffalo
Posts: 715
not alone

Don't feel bad, I took mine out of the box once, looked like all greek to me. There it sits in the box never used. Suppose I should get of my *** and attempt to figure the thing out.
Old 02-09-2013, 06:08 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
One thing you could easily do is test if it will power up and calibrate - this is done without having to install anything.


I actually found my old order for it on Pelican and just sent their customer service department a message about the problem. I don't have any expectations since it has been a ridiculous amount of time since I ordered it, but it will be interesting to see how they respond.

Last edited by Ronnie's.930; 02-09-2013 at 10:38 PM..
Old 02-09-2013, 06:36 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Turbofrog
 
smurfbus's Avatar
 
Join Date: Aug 2009
Location: Europe
Posts: 1,600
I rigged up a condensator on the powerline from a pc power unit. That helped on my 930 but I dont remember what was my problem back then? With my Audi it works just fine as it is so it might be alternator/voltage related.
__________________
************************************************** *******************************
79 930: HX40Super, MS3pro+ID1000+044+E85, Ignition: 123/TUNE/MSD6A, BB+2*turbosmart38, WMI. Weight 1110kg
Old 02-09-2013, 10:30 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Registered User
 
boosted 89's Avatar
 
Join Date: Nov 2009
Location: Ontario Canada
Posts: 134
Garage
Felipe at innovate is a good guy. I had similar issues with my LC-1 unit. Give him an email or even a call, he might be able to help find a solution.
felipe@innovatemotorsports.com

It may just be a bad lambda sensor. I think VW sells the same sensor and they are fairly cheap.
Old 02-10-2013, 05:21 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #5 (permalink)
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
Thanks for the info.
Old 02-10-2013, 08:36 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #6 (permalink)
 
Crotchety Old Bastard
 
RarlyL8's Avatar
 
Join Date: Jan 2000
Location: Huntsville, AL
Posts: 14,357
Garage
I'm going throught the same thing and should've know better due to past experience with their products. None have been plug and play and none have worked properly or as advertised. In an attempt at the KISS method I ordered an XD-16 stand alone gage. Same issue. Fired it up went throught the calibration and .... nothing. Sits in E2. My time is WAY too valuable to screw with this.
If you can get throught to customer service and can fix your issue I'm all ears. Sounds like mine has the same problem.
__________________
RarlyL8 Motorsports / M&K Exhaust - 911/930 Exhaust Systems, Turbos, TiAL, CIS Mods/Rebuilds
'78 911SC Widebody, 930 engine, 915 Tranny, K27, SC Cams, RL8 Headers & GT3 Muffler. 350whp @ 0.75bar
Brian B. (256)536-9977 Service@MKExhaust Brian@RarlyL8
Old 02-10-2013, 11:25 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #7 (permalink)
Registered
 
Join Date: May 2011
Location: West of Toronto, Canada
Posts: 203
Garage
I have 3 LM-2's in electronics storage spot in the garage. After tiring of trying to make them work I bought an AEM unit which worked perfectly and without fuss. Just got my old turbocharged BMW M6 (sorry) running with a new engine left the O2 in that was there when a rod broke in the old engine. Had some crank position sensor issues, but the AEM gauge works just as it did. The car has been sitting for about 17 months.

Anybody want my old LM-2's ?

Am expecting the engine for the 930 to be back together and in my hands this week!

Cheers,
Dave
Old 02-10-2013, 11:47 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #8 (permalink)
Registered
 
Dr J's Avatar
 
Join Date: Apr 2008
Location: Miami
Posts: 793
Hello Ronnie. I have had an Lm 2 working full time for over a year. If you can't get anything resolved I would be glad to connect it to my working components and test it out for you.
Old 02-10-2013, 12:07 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #9 (permalink)
Registered
 
Join Date: Jul 2003
Location: Back in B'ham, AL
Posts: 3,455
I'm not sure about the LM2, but I have a MTL that works great!

I had a problem with the first one, Innovative gave me a return # and in a week a had a brand new unit. No questions asked.
Old 02-10-2013, 02:40 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #10 (permalink)
Registered
 
mark houghton's Avatar
 
Join Date: Jul 2008
Location: Central Washington State
Posts: 3,893
Seems like Innovate better start listening (someone should paste a copy of this thread over to them). They're getting a lot of negative input here.

Fortunately my old LC-1 never gave me a bit of trouble and still works as designed. Granted it's basic compared to the newer versions, but it tells me all I want or need to know. The only problem is that it's takes my eyes off the road now and then.
__________________
Mark H. 1987 930, GP White, Wevo shifter, Borla exhaust, stock everything else. The result of a massive Pelicanite good will fire recovery effort. Truely an open book, ready for the slippery slopes to modification.
Old 02-10-2013, 03:34 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #11 (permalink)
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
Hello Mark. Innovate is definitely aware of problems with some of their products as they used to have a message board on their Home Page and actually disabled it sometime ago due to all the grief they were getting (now links to the old message board just take you to a page that says to contact them if you are having troubles).

Dr.J - thanks for the offer.
Old 02-10-2013, 03:50 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #12 (permalink)
 
Registered User
 
oilonly's Avatar
 
Join Date: May 2008
Posts: 1,148
I know it is a higher priced item but I found the installation and operation of the WEGO IV AFR gauge to be hassle free. JMHO
__________________
'87, Modified WUR, Billet valve, 965 downpipe, Kokeln intercooler, GHL headers, Garrett T04B K27 hybrid, Tial w/.8 bar, WEGO IV, RarlyL8 dual out, LSD
Old 02-10-2013, 04:58 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #13 (permalink)
Banned
 
Join Date: Nov 2007
Location: Rockwall, Texas
Posts: 8,760
I've seen your past posts about the WEGO and it does sound promising, and in fact, it is actually less expensive than the LM-2.
Old 02-10-2013, 05:13 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #14 (permalink)
Registered
 
Join Date: Oct 2006
Location: Chas, SC
Posts: 1,088
Wow, and I just bought a MTX-L, received it today, should I send back and go with another product...

Edit: Decided to return and go with AEM.

Edit: Should I go with the AEM Analog or Digital?
__________________
Tim
1986 930
Gone:71,2,4 914's, 70T, 71T(RS),77S

Last edited by timc; 03-21-2013 at 06:19 PM..
Old 03-21-2013, 05:55 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #15 (permalink)
Registered User
 
PrimeMvr's Avatar
 
Join Date: Dec 2010
Location: Iowa
Posts: 370
Garage
For what it's worth my MTX-L and SSI-4 have worked perfectly for two years and were a breeze to install. Just a data point. Quality control doesn't seem to be their strong point based on this and many other posts.
__________________
87 930 - Black - 3.4L/964 cams/K29/Powerhaus IC/6AL-2/B&B dual exhaust/MTX-L/235-315 Toyo R888/18" Kinesis wheels/Big Red brakes/LSD
10 997.2 Cab - Speed Yellow
83 SC Cab - Guards Red [SOLD]
17 NSX - Nouvelle Blue
Old 03-21-2013, 06:26 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #16 (permalink)
Registered User
 
jsveb's Avatar
 
Join Date: May 2007
Location: Norseman territory
Posts: 2,801
Garage
Quote:
Originally Posted by RarlyL8 View Post
I'm going throught the same thing and should've know better due to past experience with their products. None have been plug and play and none have worked properly or as advertised. In an attempt at the KISS method I ordered an XD-16 stand alone gage. Same issue. Fired it up went throught the calibration and .... nothing. Sits in E2. My time is WAY too valuable to screw with this.
If you can get throught to customer service and can fix your issue I'm all ears. Sounds like mine has the same problem.
Brian, it has been a while since I installed mine, so... You don't have a termination plug at the end of the chain do you? It is supposed to be left open.
I installed mine a while back, once I did what the manual said, it has worked ever since.
__________________
Jesper
Carrera 3.0 1975
930 1978 OEM Matte Schwartz, ANDIAL IC, BL WUR, SC cams. LMA-3 w. XD-16 and CP transducer
www.stauningwhisky.dk
Old 03-21-2013, 06:54 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #17 (permalink)
Chain fence eating turbo
 
Join Date: Dec 2008
Location: Austin, TX
Posts: 8,844
I always get scared when I read about Innovate but I haven't had any issues with their MTX-L integrated unit.

Fingers crossed.
Old 03-21-2013, 08:56 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #18 (permalink)
Wide body, molester.
 
H20 LOL's Avatar
 
Join Date: Dec 2011
Location: San Antonio, Tx
Posts: 153
Quote:
Originally Posted by Tippy View Post
I always get scared when I read about Innovate but I haven't had any issues with their MTX-L integrated unit.

Fingers crossed.
Oh you're screwed now.
__________________
91- 964T, It's upkeep treats me like a skinny white kid in prison, but it does give me a reach around every now and then by letting me drive it. That's not so bad.
Old 03-21-2013, 09:49 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #19 (permalink)
Chain fence eating turbo
 
Join Date: Dec 2008
Location: Austin, TX
Posts: 8,844
Probably so. You even had issues with PLX. Now working in the electronics manufacturing biz, I wonder why there is such an issue with these WBO2 systems? What's the failure?

Old 03-21-2013, 10:01 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #20 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 12:24 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.