Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Technical BBS > 1- Porsche Technical Forums > 911 Engine Rebuilding Forum

Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Junior Member
 
Join Date: Aug 2005
Posts: 2
low oil pressure

i do not have a porsche but i am in dire need of some assistance. i recently built a 357 for my camaro, put a 502 racing cam, and alluminum heads. i don't really know all the specs but i know that the bearing clearances were checked and were set at .002. when i start my engine it runs very well but my oil pressure gauge reads very low at a about 5-10 psi range. i double checked to see if this was correct by using a test gauge and it was. we just fired it up yesturday and broke it in. it ran for about 30 min with no problems. i have no idea what could be wrong. please help!!!
Old 08-01-2005, 07:55 AM
  Pelican Parts Technical Article Directory    Reply With Quote #1 (permalink)
JOT MON ABBR OTH
 
Groesbeck Hurricane's Avatar
 
Join Date: Feb 2001
Location: Tulsa
Posts: 3,183
did you use a new oil pump, re-built pump, or the old pump? what grade of oil did you use?
__________________
David
'83 SC Targa (mine) MANLY babyblue honda '00 F250 7.3L (MINE!)
'15 F250 Gas (Her Baby) '95 993 (sold )
I don't take scalps. I'm civilized like white man now, I shoot man in back.
Old 08-01-2005, 09:50 AM
  Pelican Parts Technical Article Directory    Reply With Quote #2 (permalink)
Registered User
 
Join Date: May 2005
Location: Bothell, WA
Posts: 239
The oil pump pickup tube is a common problem. Did you rebuild or check the oil pump? There is also a spring that regulates the pressure that could be having a problem.

Rex
__________________
1975 911s
1997 Saab 900s
Old 08-01-2005, 09:51 AM
  Pelican Parts Technical Article Directory    Reply With Quote #3 (permalink)
Registered User
 
HawgRyder's Avatar
 
Join Date: Feb 2002
Location: Langley, BC Canada
Posts: 2,865
Garage
Send a message via ICQ to HawgRyder
We had a problem with a brand new high volume pump once.
The pick-up was too close to the bottom of the pan and it was sucking the metal pan upwards and blocking the screened pipe to the pump.
This is a very difficult problem to find as the bottom of the pan only has to move a few thou to close off the flow.
Just another thing to check....good luck.
Bob
__________________
Bob Hutson
Old 08-01-2005, 05:39 PM
  Pelican Parts Technical Article Directory    Reply With Quote #4 (permalink)
Still Doin Time
 
asphaltgambler's Avatar
 
Join Date: Nov 2004
Location: Nokesville, Va.
Posts: 5,039
You may have a stuck open pressure relief valve in your pump.
__________________
'07 Jeep SRT-8 - Hauls groceries and Hauls *ss
'85 Guards Red Targa - F@#king Money Pit
'95 Road King w/117ci - No time to ride, see above
'77 Sportster Pro-Street Drag Bike w/93ci - Sold to collector
'72 Yamaha CS5 200 Twin - Sold to fellow Pelicanite
Old 08-01-2005, 06:40 PM
  Pelican Parts Technical Article Directory    Reply With Quote #5 (permalink)
Junior Member
 
Join Date: Aug 2005
Posts: 2
appearently fram air filter is not a very good one and is reffered to as a mickey mouse filter. i went and bought and installed a wmx nascar high performance filter. which i used to replace the fram air filter. those air filters are only good for engines that put out up to 50 psi and i was running at 70 psi with the high performance cam. basically the pressure crushed the fram oil filter. thank you for all of your help and stay away from those fram filters!!!
Old 08-03-2005, 11:32 AM
  Pelican Parts Technical Article Directory    Reply With Quote #6 (permalink)
JOT MON ABBR OTH
 
Groesbeck Hurricane's Avatar
 
Join Date: Feb 2001
Location: Tulsa
Posts: 3,183
Post Filter Study

http://minimopar.knizefamily.net/oilfilterstudy.html
__________________
David
'83 SC Targa (mine) MANLY babyblue honda '00 F250 7.3L (MINE!)
'15 F250 Gas (Her Baby) '95 993 (sold )
I don't take scalps. I'm civilized like white man now, I shoot man in back.
Old 08-03-2005, 12:27 PM
  Pelican Parts Technical Article Directory    Reply With Quote #7 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 12:38 AM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2017 Pelican Parts LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.