Thread: No intercooler
View Single Post
T77911S T77911S is offline
Registered User
 
T77911S's Avatar
 
Join Date: Oct 2006
Location: MYR S.C.
Posts: 8,792
I have tried to come with parts to plumb out the IC (and turbo) just to work on the car and have it run.

you can run it without the muffler or anything attached to the hot side of the turbo to check for oil leaks. you can even drive it that way.

I have the same turbo.
at the oil supply side to the turbo I have an adapter at the rear of the engine with a check ball in there. on the bottom side of the turbo I have a catch can about the size of a soda can.
I did the pump test a long time ago. I don't remember a lot of oil coming out of the turbo but my scavenge pump kept up.

what is going on exactly
where are you seeing oil?
check the return line for blockage
rebuild the scavenge pump.
sorry, I don't remember everything you have done.

when I filled my muffler with oil it took a long time to burn it off. man I left a smoke screen like you would not believe for a good 30 minutes. I even tried to wash it out first
__________________
86 930 42kmiles [__] RUNNING:[__] NOT RUNNING: ____77 911S widebody: SOLD
88 BMW 325is 200K+ [__] RUNNING: [__] NOT RUNNING:
05 BMW 330CI 130K:: [__] RUNNING: [__] NOT RUNNING:
08 VOLVO V70 190K:: [__] RUNNING: [__] NOT RUNNING:
90 B2200[] RUNNING:[_] NOT RUNNING:__2000 MER E320 WAGON [_] WRECKED:[]RUNNING:
Old 09-26-2017, 07:03 AM
  Pelican Parts Technical Article Directory    Reply With Quote #15 (permalink)