Thread: euro DME issues
View Single Post
nynor nynor is offline
winter-hater club member
 
nynor's Avatar
 
Join Date: Oct 2003
Location: salt lake city, utah
Posts: 24,707
euro DME issues

i have two DME's for my vehicle. the original one mostly works fine. the main issue is with the second one, which is the early euro version, with advanced timing, etc.

the problems with the euro DME are as follows: very difficult to start the vehicle when the engine is cold, runs rough (and i mean ROUGH) until the engine warms, and most alarming of all is that it will simply stop running. the first time it stopped running, i was on the freeway cruising at about 75 MPH and the engine simply stopped running. i pulled over, could not get the car to start, after about 5 minutes, the car started back up at the first turn of the key. the next day, it did the same thing, only this time i had the original DME with me, which i swapped out on the side of the freeway and the car ran immediately. needless to say, i have been running the original DME ever since and the car has not had those problems.

i would really like to be using the euro DME, as the car has noticeably better power and revs much faster. any ideas as to the nature of the problem will be appreciated.
__________________
2000 Corvette - ????, 2007 Buell XB9R - Astrid, 1996 Discovery - Piglet, 2000 Forester

"COOL PRIUS!" - Nobody Ever
Old 10-14-2003, 09:02 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)