View Single Post
Alan L Alan L is offline
Registered User
 
Alan L's Avatar
 
Join Date: Apr 2006
Location: New Zealand
Posts: 3,545
Quote:
Originally Posted by RarlyL8 View Post
This problem has nothing to do with the overboost switch, it is the air meter plate switch circuit. That circuit operates ass-backwards by using ground to turn the pumps on. If there is a ground fault anywhere in the circuit it will be defeated and the pumps will run when the key is on. You have to find where the ground is, could be a broken or corroded wire, so the circuit must be traced.
Agree.
Not o/boost circuit - it is working as supposed. Pumps running (key On), he pulls o/boost terminal, pumps stop. As they should. That part of circuit is correct. His symptoms are same as if airplate plug is pulled = disrupted circuit to earth. Which would look like a likely bet there is a faulty earth in that leg of the circuit. Which is the sort of thing that would explain why it was OK, then suddenly acting like this.
Alan
__________________
83 SC, 82 930 (track) - Stock except for RarlyL8 race headers, RarlyL8 Zork, K27-7006, 22/28 T bars, 007 Fuel head, short 3&4 gears, NGK AFR, Greddy EBC (on the slippery slope), Wevo engine mounts, ERP rear camber adjust and mono balls, Tarret front monoball camber adjust, Elgin cams, 38mm ported heads, 964 IC. 380rwhp @ 0.8bar Apart from above, bone stock:-)
Old 03-19-2018, 10:24 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #26 (permalink)