Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    
Go Back   Pelican Parts Technical BBS > 2- BMW Forums > BMW Technical Forums > BMW 5-Series E28/E34/E39

Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
JMI JMI is offline
Junior Member
 
Join Date: Sep 2006
Posts: 3
Ignition coil and idle\stall problem

1989 535iA - M30 Engine

Been beating my head over an idle that runs fine (700 rpm) then suddenly will drop a few hundred rpm and at that point either stall completely or surge to 1100-1200 rpm before dropping back to 700 rpm. Have inspected all the usaul suspects.
Could a bad ignition coil cause that sort of problem?

Thanks

Jim
Old 09-07-2006, 08:59 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #1 (permalink)
Living on borrowed time!
 
JonyRR's Avatar
 
Join Date: Dec 2003
Location: Tacoma, WA, USA
Posts: 6,961
air leak?
if it settles down when warm, I say air elak.
__________________
Better a has-been than a wanna-be

'I am John Andrew Moffett of the Clan Moffat and by god I live, love, seek, fail, grieve and die as I so choose and I call no man master save me'.
Old 09-08-2006, 01:20 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #2 (permalink)
JMI JMI is offline
Junior Member
 
Join Date: Sep 2006
Posts: 3
Have looked for vacuum leaks - don't see any. TPS & ECT & CPS & AFM all check out. Have changed ICV and distributor and rotor. I'm at a loss.
Oxygen sensor ihas only 18000 miles on it.
Beginning to suspect fuel problem, but tired of throwing parts and money at the problem.
Help!
Old 09-08-2006, 06:10 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #3 (permalink)
Living on borrowed time!
 
JonyRR's Avatar
 
Join Date: Dec 2003
Location: Tacoma, WA, USA
Posts: 6,961
'looked for vacuum leaks'
did you try the propane (or contact cleaner) test;
run engine, spray cleaner or propane around the usual suspect points, listen for idle to change.
__________________
Better a has-been than a wanna-be

'I am John Andrew Moffett of the Clan Moffat and by god I live, love, seek, fail, grieve and die as I so choose and I call no man master save me'.
Old 09-15-2006, 03:29 PM
  Recommend this thread for the PelicanWiki    Reply With Quote #4 (permalink)
JMI JMI is offline
Junior Member
 
Join Date: Sep 2006
Posts: 3
Idle Problem Fixed

It turns out the problem was a bad pulse generator/cylinder ID sensor: see #9. This is sometime included with new plug wires but check to make sure it is. They should be changed together at a regular interval, say 50,000 to 100,000 miles.

The car drives like a dream now
Old 10-19-2006, 03:57 AM
  Recommend this thread for the PelicanWiki    Reply With Quote #5 (permalink)
Old 10-19-2006, 03:57 AM
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 



All times are GMT -8. The time now is 02:17 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.