Pelican Parts Forums

Pelican Parts Forums (http://forums.pelicanparts.com/)
-   BMW X1, X3, X4, X5 & X6 Forum (http://forums.pelicanparts.com/bmw-x1-x3-x4-x5-x6-forum/)
-   -   2007 X3 N52 3.0si Issues (http://forums.pelicanparts.com/bmw-x1-x3-x4-x5-x6-forum/1024046-2007-x3-n52-3-0si-issues.html)

Jason Porter 03-19-2019 12:29 PM

2007 X3 N52 3.0si Issues
 
I keep getting a cylinder number 4 misfire code. Sometimes I get a DME code and sometimes I get a Vanos code, but always cylinder 4 misfire. I have replaced plugs and coils and checked all of my ground wires. I have done a leak down test on cylinder for and got 3% leakage. Also switched #4&5 injectors, still cyl 4 misfire. Continuity is good on DME harness wires from unit to coil plug and from coil plug to ground. Idles like crap, runs fantastic.

I used to work at Pelican as a Porsche guy, but the BMW's are not completely in my wheelhouse.

Executechs10 11-10-2019 09:47 PM

I have a 2007 x3 as well. Check for oil in the wells. I needed to change the valve cover gaskets due to oil leaking in the spark plug / coil wells. The gasket kit should come with 6 small gaskets for the plugs / coils and the large valve cover gasket. Oil in the well will cause the coils to swell and misfire. Also check the connectors to the coils, had a frayed wire too. Good Luck-


All times are GMT -8. The time now is 05:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website


DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.