Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > BMW Forums > BMW Technical Forums > BMW X1, X3, X4, X5 & X6 Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered User
 
Join Date: Jul 2014
Location: Boonton, NJ
Posts: 28
E70 X5 Wipers and sensors going nuts

Hello,

I've been having an issue with my father's X5. Right from starting up, the wipers go on, and several sensor malfunction notices chime on the flatscreen [DSC, AWD, restraint system, and a few others]. I thought it was due to not driving it enough to charge the battery, but I ruled that out for sure today because I drove it all over the place.

Is there a sensor, fuse, particular location of a wire problem that anyone else has experience with? Thank you in advance for any info!

Kyle
__________________
Kyle@rebadge.com
+001.973.634.2664
http://rebadge.com
http://Facebook.com/rebadge
http://Instagram.com/rebadge
Old 10-03-2019, 02:35 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
Join Date: Mar 2019
Posts: 7
Understood...Charge the battery up fully....

Sent from my SM-G531H using Tapatalk
Old 10-03-2019, 07:04 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered User
 
Join Date: Jul 2014
Location: Boonton, NJ
Posts: 28
Iím pretty confident itís not the battery. Furthermore, taking the battery out and charging it is another issue; the battery would need to be re-registered at a dealer.
Old 10-06-2019, 05:22 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Administrator
 
Dmitry at Pelican Parts's Avatar
 
Join Date: Aug 2016
Location: Los Angeles, CA
Posts: 5,163
Garage
Quote:
Originally Posted by Rebadge.com View Post
Hello,

I've been having an issue with my father's X5. Right from starting up, the wipers go on, and several sensor malfunction notices chime on the flatscreen [DSC, AWD, restraint system, and a few others]. I thought it was due to not driving it enough to charge the battery, but I ruled that out for sure today because I drove it all over the place.

Is there a sensor, fuse, particular location of a wire problem that anyone else has experience with? Thank you in advance for any info!

Kyle

Hey Kyle - have you tried pulling the car's fault codes? This will likely give you a good idea where the issue is coming from.
Old 10-07-2019, 03:03 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 11:08 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.