Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > BMW Forums > BMW Technical Forums > BMW Z3/Z4 Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Alpalz3
 
Join Date: Sep 2018
Location: Marton, New Zealand
Posts: 5
Radio dead, but used to work?,.......

Removed the radio for another job and on re-assembly it didn't work, ......radio fuse is ok as are fuses under bonnet. What am I missing? New to Z3's so I'm on a learning curve here.
Regards,
Alpalz3
Old 09-04-2018, 09:32 PM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered User
 
harborman's Avatar
 
Join Date: Dec 2009
Location: SW MIchigan
Posts: 2,023
Garage
Quote:
Originally Posted by Alpalz3 View Post
Removed the radio for another job and on re-assembly it didn't work, ......radio fuse is ok as are fuses under bonnet. What am I missing? New to Z3's so I'm on a learning curve here.
Regards,
Alpalz3
On my 2000 Z3 if you disconnect the battery the radio will no longer work when reconnected, unless you program in the security code. A five digit number.
__________________
1986 928S
32 valve engine
All stock, automatic, 539 Weissgold Metallic, 70K original miles, Hankook Ventus 2 tires.
Previously owned: 67 Vette, 427 L88 Stingray, 74 De Tomaso Pantera L
Old 08-12-2019, 06:45 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 07:22 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.