Pelican Parts
Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   Pelican Parts Forums > BMW Forums > BMW Technical Forums > BMW Z3/Z4 Forum


Reply
 
LinkBack Thread Tools Rate Thread
Author
Thread Post New Thread    Reply
Registered
 
Join Date: Aug 2020
Posts: 3
Z3 wheel speed sensor

In have just tried to replace the rear wheel sensor on my 1999 2.8l Z3
The socket in the hub is about 15mm dia. but the new unit is about 18mm. Is this normal? It will take a lot of force to install it even if well greased.

Old 08-13-2020, 06:54 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #1 (permalink)
Registered
 
harborman's Avatar
 
Join Date: Dec 2009
Location: SW MIchigan
Posts: 2,114
Garage
Quote:
Originally Posted by Mark1999Z3 View Post
In have just tried to replace the rear wheel sensor on my 1999 2.8l Z3
The socket in the hub is about 15mm dia. but the new unit is about 18mm. Is this normal? It will take a lot of force to install it even if well greased.
Does not sound right to me. Got the correct part?
__________________
1986 928S
32 valve engine
All stock, automatic, 539 Weissgold Metallic, 70K original miles, Hankook Ventus 2 tires.
Previously owned: 67 Vette, 427 L88 Stingray, 74 De Tomaso Pantera L. Latest addition: 2000 BMW Z3 Roadster
Old 08-13-2020, 10:46 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #2 (permalink)
Registered
 
Join Date: Aug 2020
Posts: 3
Wrong part?

I have asked the supplier(not BMW) to check, but have not yet had an answer, It looks identical to the old one except for the sensor diameter. I assume it should just be a push fit, but the old one put up a devil of a fight to remove I had to drill it out. Has anyone replaced one of these?
Thanks Mark
Old 08-14-2020, 02:55 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #3 (permalink)
Registered
 
Join Date: Aug 2020
Posts: 3
SCS Update

Well I managed to sand and grease the new one enough to get it in the hub, but still no success. then tried to get the C110 OB2 diaignostic unit, but it seems it only works on 2000 Z3s onwards. Does anyone know of a diagnostic tool that works with my 1999 Z3?
and preferably does not cost the earfh.
Thanks Mark

Old 08-25-2020, 11:00 AM
  Pelican Parts Catalog | Tech Articles | Promos & Specials    Reply With Quote #4 (permalink)
Reply

Thread Tools
Rate This Thread
Rate This Thread:

 


All times are GMT -8. The time now is 12:08 PM.


 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2020 Pelican Parts, LLC - Posts may be archived for display on the Pelican Parts Website -    DMCA Registered Agent Contact Page
 

DTO Garage Plus vBulletin Plugins by Drive Thru Online, Inc.